Agrega por teclado las dimensiones de un vector

¡Haz clic para puntuar este proyecto!
(Votos: 3 Promedio: 2.3)

Pedir por teclado el tamaño de un arreglo de números y pedir los valores numéricos con los que se rellena. Los valores no se pueden repetir, por lo tanto, deberá de encargarse de buscar cada número que lea y verificar que no se haya leído antes. Mostrar el arreglo con los valores al final.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeInt_Site
        Escribir "TAMAÑO DEL VECTOR : "
        Leer N
        Dimension vector[N]
        Para f = 1 Hasta N Con Paso 1 Hacer
            Escribir Sin Saltar "VALOR ",f,"/",n, " : "
            Leer vector[f]		
            i = 1;
            Mientras (f > 1 Y i != f) Hacer
                Si (vector[i] == vector[f]) Entonces
                    Escribir "VALOR REPETIDO"
                    i = f - 1
                    f = f - 1
                SiNo
                    i = i + 1
                FinSi			
            FinMientras				
        FinPara
        Escribir ""
        Para f = 1 Hasta N Con Paso 1 Hacer
            Escribir Sin Saltar vector[f], "  "
        FinPara
        Escribir ""
    FinAlgoritmo
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

    Subir