Cargar un vector con el Número Ingresado

¡Haz clic para puntuar este proyecto!
(Votos: 0 Promedio: 0)
¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Dimension lista[20]
        Escribir "Ingrese Número del 1 - 20 : "
        Leer num
        //Registra número en el Array	
        Si num >0 Y num <= 20 Entonces
            lista[num] = num
            //Mostrar Array	
            Para contador = 1 hasta 20 con paso 1 hacer			
                Escribir lista[contador]				
            FinPara
            Escribir "El valor se guardo en la posición : ", num		
        SiNo
            Escribir "Número mal Ingresado"
        Fin Si	
    FinAlgoritmo
    

    Lenguaje C

       
    #include<stdio.h>
    int main() {
        int contador, num, lista[20];	
        printf("Ingrese Numero del 1 - 20 : ");
        scanf("%i",&num);
        for (contador=0;contador<=19;contador+=1) {
            lista[contador] = 0;
        }
        /* Registra número en el Array  */
        if (num>0 && num<=20) {
            lista[num-1] = num;
            /* Mostrar Array  */
            for (contador=0;contador<=19;contador+=1) {
                printf("%i\n",lista[contador]);
            }
            printf("El valor se guardo en la posicion : %d\n",num);
        } else {
            printf("Numero mal Ingresado\n");
        }
        return 0;
    }
    

    C++

           
    #include<iostream>
    using namespace std;
    int main() {
        int contador, num, lista[20];	
        cout << "Ingrese Numero del 1 - 20 : ";
        cin >> num;
        for (contador=0;contador<=19;contador++) {
            lista[contador] = 0;
        }
        // Registra número en el Array 
        if (num>0 && num<=20) {
            lista[num-1] = num;
            // Mostrar Array 
            for (contador=0;contador<=19;contador++) {
                cout << lista[contador] << endl;
            }
            cout << "El valor se guardo en la posicion : " << num << endl;
        } else {
            cout << "Numero mal Ingresado" << endl;
        }
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir