Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

03. Cargar un vector con el Número Ingresado.

En un array de 20 elementos, ingresar un número cualquiera y cargar dicho array con el número ingresado.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_03
	
    Dimension lista[20]
	
    Escribir "Ingrese Número del 1 - 20 : "
    Leer num
	
    //Registra número en el Array	
    Si num >0 Y num <= 20 Entonces
        lista[num] = num
		
        //Mostrar Array	
        Para contador = 1 hasta 20 con paso 1 hacer			
            Escribir lista[contador]				
        FinPara
			
        Escribir "El valor se guardo en la posición : ", num		
    SiNo
        Escribir "Número mal Ingresado"
    Fin Si	
		
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_03
	
    Definir lista, num, contador como Entero;
    Dimension lista[20];
	
    Escribir "Ingrese Número del 1 - 20 : ";
    Leer num;
	
    Para contador <- 0 hasta 19 con paso 1 hacer			
        lista[contador] <- 0;
    FinPara
	
    //Registra número en el Array	
    Si num > 0 Y num <= 20 Entonces
        lista[num-1] <- num;
		
        //Mostrar Array	
        Para contador <- 0 hasta 19 con paso 1 hacer			
            Escribir lista[contador];
        FinPara
        Escribir "El valor se guardo en la posición : ", num;
    SiNo
        Escribir "Número mal Ingresado";
    FinSi	
		
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
int main() {
    int contador, num, lista[20];	
	
    printf("Ingrese Numero del 1 - 20 : ");
    scanf("%i",&num);
	
    for (contador=0;contador<=19;contador+=1) {
        lista[contador] = 0;
    }
	
    /* Registra número en el Array  */
    if (num>0 && num<=20) {
        lista[num-1] = num;
		
        /* Mostrar Array  */
        for (contador=0;contador<=19;contador+=1) {
            printf("%i\n",lista[contador]);
        }
        printf("El valor se guardo en la posicion : %d\n",num);
    } else {
        printf("Numero mal Ingresado\n");
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

           
#include<iostream>
using namespace std;
int main() {
    int contador, num, lista[20];	
	
    cout << "Ingrese Numero del 1 - 20 : ";
    cin >> num;
	
    for (contador=0;contador<=19;contador++) {
        lista[contador] = 0;
    }
	
    // Registra número en el Array 
    if (num>0 && num<=20) {
        lista[num-1] = num;
        
        // Mostrar Array 
        for (contador=0;contador<=19;contador++) {
            cout << lista[contador] << endl;
        }
        cout << "El valor se guardo en la posicion : " << num << endl;
    } else {
        cout << "Numero mal Ingresado" << endl;
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    lista = [int() for ind0 in range(20)]
    print("Ingrese Número del 1 - 20 : ")
    num = int(input())
    for contador in range(20):
        lista[contador] = 0
    # Registra número en el Array
    if num>0 and num<=20:
        lista[num-1] = num
        # Mostrar Array 
        for contador in range(20):
            print(lista[contador])
        print("El valor se guardo en la posición : ",num)
    else:
        print("Número mal Ingresado")
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site