Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

07. Mostrar los números positivos, negativos y neutros del array

Hacer un programa que permita ingresar 10 valores a un array seguido muestre cuantos son positivos, cuantos negativos y cuantos son nulos.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_07
	
    Dimension vector[10]
    positivo = 0
    negativo = 0
    nulo = 0
	
    //Ingresa 10 valores al array
    Para f = 1 hasta 10 con paso 1 hacer			
        Escribir "Ingrese Número ", f, " : "		
        Leer vector[f]				
    FinPara		
	
    //Muestra Positivos, Negativos, Nulos
    Para f = 1 hasta 10 con paso 1 hacer						
        Si vector[f] = 0 Entonces
            nulo = nulo + 1
        SiNo
            Si vector[f] > 0 Entonces
                positivo = positivo + 1
            SiNo
                negativo = negativo + 1
            Fin Si
        Fin Si		
    FinPara
	
    Escribir "Total de Nulos : ", nulo
    Escribir "Total de Positivos : ", positivo
    Escribir "Total de Negativos : ", negativo
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_07
	
    Definir vector, positivo, negativo, nulo, f como Entero;
    Dimension vector[10];
	
    positivo <- 0;
    negativo <- 0;
    nulo <- 0;
	
    //Ingresa 10 valores al array
    Para f <- 0 hasta 9 con paso 1 hacer			
        Escribir "Ingrese Número ", f + 1, " : ";
        Leer vector[f];
    FinPara		
	
    //Muestra Positivos, Negativos, Nulos
    Para f <- 0 hasta 9 con paso 1 hacer						
        Si vector[f] = 0 Entonces
            nulo <- nulo + 1;
        SiNo
            Si vector[f] > 0 Entonces
                positivo <- positivo + 1;
            SiNo
                negativo <- negativo + 1;
            FinSi
        FinSi
    FinPara
	
    Escribir "Total de Nulos : ", nulo;
    Escribir "Total de Positivos : ", positivo;
    Escribir "Total de Negativos : ", negativo;
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
int main() {
    int f, negativo, nulo, positivo, vector[10];
	
    positivo = 0;
    negativo = 0;
    nulo = 0;
	
    /* Ingresa 10 valores al array */
    for (f=0;f<=9;f+=1) {
        printf("Ingrese Numero %d : ",f+1);
        scanf("%i",&vector[f]);
    }
    /* Muestra Positivos, Negativos, Nulos */
    for (f=0;f<=9;f+=1) {
        if (vector[f]==0) {
            nulo = nulo+1;
        } else {
            if (vector[f]>0) {
                positivo = positivo+1;
            } else {
                negativo = negativo+1;
            }
        }
    }
    printf("\nTotal de Nulos : %d\n",nulo);
    printf("Total de Positivos : %d\n",positivo);
    printf("Total de Negativos : %d\n",negativo);
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main() {
    int f, negativo, nulo, positivo, vector[10];
	
    positivo = 0;
    negativo = 0;
    nulo = 0;
    // Ingresa 10 valores al array
    for (f=0;f<=9;f++) {
        cout << "Ingrese Numero " << f+1 << " : ";
        cin >> vector[f];
    }
    // Muestra Positivos, Negativos, Nulos
    for (f=0;f<=9;f++) {
        if (vector[f]==0) {
            nulo = nulo+1;
        } else {
            if (vector[f]>0) {
                positivo = positivo+1;
            } else {
                negativo = negativo+1;
            }
        }
    }
    cout << endl << "Total de Nulos : " << nulo << endl;
    cout << "Total de Positivos : " << positivo << endl;
    cout << "Total de Negativos : " << negativo << endl;
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    vector = [int() for ind0 in range(10)]
    positivo = 0
    negativo = 0
    nulo = 0
    # Ingresa 10 valores al array
    for f in range(10):
        print("Ingrese Número ",f+1," : ")
        vector[f] = int(input())
    # Muestra Positivos, Negativos, Nulos
    for f in range(10):
        if vector[f]==0:
            nulo = nulo+1
        else:
            if vector[f]>0:
                positivo = positivo+1
            else:
                negativo = negativo+1
    print("Total de Nulos : ",nulo)
    print("Total de Positivos : ",positivo)
    print("Total de Negativos : ",negativo)
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site