Mostrar los números positivos, negativos y neutros del array

¡Haz clic para puntuar este proyecto!
(Votos: 3 Promedio: 4.3)

Hacer un programa que permita ingresar 10 valores a un array seguido muestre cuantos son positivos, cuantos negativos y cuantos son nulos.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Dimension vector[10]
        positivo = 0
        negativo = 0
        nulo = 0
        //Ingresa 10 valores al array
        Para f = 1 hasta 10 con paso 1 hacer			
            Escribir "Ingrese Número ", f, " : "		
            Leer vector[f]				
        FinPara		
        //Muestra Positivos, Negativos, Nulos
        Para f = 1 hasta 10 con paso 1 hacer						
            Si vector[f] = 0 Entonces
                nulo = nulo + 1
            SiNo
                Si vector[f] > 0 Entonces
                    positivo = positivo + 1
                SiNo
                    negativo = negativo + 1
                Fin Si
            Fin Si		
        FinPara
        Escribir "Total de Nulos : ", nulo
        Escribir "Total de Positivos : ", positivo
        Escribir "Total de Negativos : ", negativo
    FinAlgoritmo
    

    Lenguaje C

        
    #include<stdio.h>
    int main() {
        int f, negativo, nulo, positivo, vector[10];
        positivo = 0;
        negativo = 0;
        nulo = 0;
        /* Ingresa 10 valores al array */
        for (f=0;f<=9;f+=1) {
            printf("Ingrese Numero %d : ",f+1);
            scanf("%i",&vector[f]);
        }
        /* Muestra Positivos, Negativos, Nulos */
        for (f=0;f<=9;f+=1) {
            if (vector[f]==0) {
                nulo = nulo+1;
            } else {
                if (vector[f]>0) {
                    positivo = positivo+1;
                } else {
                    negativo = negativo+1;
                }
            }
        }
        printf("\nTotal de Nulos : %d\n",nulo);
        printf("Total de Positivos : %d\n",positivo);
        printf("Total de Negativos : %d\n",negativo);
        return 0;
    }
    

    C++

       
    #include<iostream>
    using namespace std;
    int main() {
        int f, negativo, nulo, positivo, vector[10];
        positivo = 0;
        negativo = 0;
        nulo = 0;
        // Ingresa 10 valores al array
        for (f=0;f<=9;f++) {
            cout << "Ingrese Numero " << f+1 << " : ";
            cin >> vector[f];
        }
        // Muestra Positivos, Negativos, Nulos
        for (f=0;f<=9;f++) {
            if (vector[f]==0) {
                nulo = nulo+1;
            } else {
                if (vector[f]>0) {
                    positivo = positivo+1;
                } else {
                    negativo = negativo+1;
                }
            }
        }
        cout << endl << "Total de Nulos : " << nulo << endl;
        cout << "Total de Positivos : " << positivo << endl;
        cout << "Total de Negativos : " << negativo << endl;
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir