Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

12. Buscar un elemento dentro de un arreglo que pedimos por teclado. Indicar la posición donde se encuentra. Si hay más de uno, indicar igualmente la posición.

PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Proceso www_PSeInt_Site
	
    Dimension arreglo[10];
	
    Para f = 1 Hasta 10 Con Paso 1 Hacer
        arreglo[f] = azar(30)
    FinPara	
    Escribir "VALOR A BUSCAR DE (0 - 29): "
    Leer num
	
    Escribir ""
    Escribir "VALORES DEL ARREGLO "
    Para f = 1 Hasta 10 Con Paso 1 Hacer
        Escribir Sin Saltar arreglo[f], "  "
    FinPara
    Escribir ""	
    Escribir ""
	
    Para f = 1 Hasta 10 Con Paso 1 Hacer
        Si (num == arreglo[f]) Entonces
            Escribir "EL VALOR ESTÁ EN LA POSCICIÓN : ", f+1
            int = 1
        FinSi		
    FinPara				
    Si (int == 0) Entonces
        Escribir "VALOR NO ENCONTRADA"
    FinSi
	
FinProceso
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Proceso www_PSeInt_Site

    Definir f, arreglo, num, int como Entero;
    Dimension arreglo[10];
	
    int <- 0;

    Para f <- 0 Hasta 9 Con Paso 1 Hacer
        arreglo[f] <- azar(30);
    FinPara	
    Escribir "VALOR A BUSCAR DE (0 - 29): ";
    Leer num;
	
    Escribir "";
    Escribir "VALORES DEL ARREGLO ";
    Para f <- 0 Hasta 9 Con Paso 1 Hacer
        Escribir Sin Saltar arreglo[f], "  ";
    FinPara
    Escribir "";
    Escribir "";
	
    Para f <- 0 Hasta 9 Con Paso 1 Hacer
        Si (num == arreglo[f]) Entonces
            Escribir "EL VALOR ESTÁ EN LA POSCICIÓN : ", f+1;
            int <- 1;
        FinSi		
    FinPara				
    Si (int == 0) Entonces
        Escribir "VALOR NO ENCONTRADA";
    FinSi
	
FinProceso
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site