Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

05. Carga números aleatorios | Vector.

Ingresar 20 números aleatorios a un array, luego muestra una lista de las posiciones que ocupan los números pares.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_05
	
    Dimension vector[20]
	
    //Ingresa 20 números aleatorios al array
    Para f = 1 hasta 20 con paso 1 hacer			
        Escribir "Ingrese Número ", f, " : "		
        Leer vector[f]				
    FinPara		
	
    //Muestra la Lista de los Pares
    Para f = 1 hasta 20 con paso 1 hacer					
        Si (vector[f] mod 2) = 0 Entonces
            Escribir "vector[",f,"]=", vector[f]		
        Fin Si		
    FinPara
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_05
	
    Definir vector, f como Entero;
    Dimension vector[20];
	
    //Ingresa 20 números aleatorios al array
    Para f <- 0 hasta 19 con paso 1 hacer			
        Escribir "Ingrese Número ", f, " : ";
        Leer vector[f];
    FinPara		
	
    //Muestra la Lista de los Pares
    Para f <- 0 hasta 19 con paso 1 hacer					
        Si (vector[f] mod 2) = 0 Entonces;
            Escribir "vector[",f,"]=", vector[f];
        FinSi
    FinPara
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
int main() {
    int f;
    int vector[20];
    /* Ingresa 20 números aleatorios al array */
    for (f=0;f<=19;f+=1) {
        printf("Ingrese Numero %i : ",f);
        scanf("%i",&vector[f]);
    }
	
    /* Muestra la Lista de los Pares */
    printf("\n");
    for (f=0;f<=19;f+=1) {
        if ((vector[f]%2)==0) {
            printf("vector[%i]=%i\n",f,vector[f]);
        }
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main() {
    int f;
    int vector[20];
    // Ingresa 20 numeros aleatorios al array
    for (f=0;f<=19;f++) {
        cout << "Ingrese Numero " << f << " : ";
        cin >> vector[f];
    }
    // Muestra la Lista de los Pares
    cout << " " << endl;
    for (f=0;f<=19;f++) {
        if ((vector[f]%2)==0) {
            cout << "vector[" << f << "]=" << vector[f] << endl;
        }
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    vector = [int() for ind0 in range(20)]
    # Ingresa 20 números aleatorios al array
    for f in range(20):
        print("Ingrese Número ",f," : ")
        vector[f] = int(input())
    # Muestra la Lista de los Pares
    for f in range(20):
        if (vector[f]%2)==0:
            print("vector[",f,"]=",vector[f])
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site