Cantidad de pares e impares

¡Haz clic para puntuar este proyecto!
(Votos: 9 Promedio: 3.4)

Ingresar 10 valores numéricos a un array y mostrar cuantos son pares y cuantos son impares.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Dimension array[10]
        //Cargar Array - 10 Números Impares
        Para contador = 1 hasta 10 con paso 1 hacer
            Escribir "Ingrese Número " , contador , " : "
            Leer array[contador]	
        FinPara
        //Mostrar Array
        pares = 0
        impares = 0
        Para contador = 1 hasta 10 con paso 1 hacer
            Si array[contador] Mod 2 = 0 Entonces		
                pares = pares + 1
            SiNo
                impares = impares + 1
            Fin Si
        FinPara
        Escribir "PARES INGRESADOS : " , pares
        Escribir "IMPARES INGRESADOS : " , impares
    FinAlgoritmo
    

    Lenguaje C

       
    #include<stdio.h>
    int main() {
        int contador, impares, pares, array[10];
        /* Cargar Array - 10 Números Impares */
        for (contador=0;contador<=9;contador+=1) {
            printf("Ingrese Numero %d : ",contador+1);
            scanf("%i",&array[contador]);
        }
        /* Mostrar Array */
        pares = 0;
        impares = 0;
        for (contador=0;contador<=9;contador+=1) {
            if (array[contador]%2==0) {
                pares = pares+1;
            } else {
                impares = impares+1;
            }
        }
        printf("\nPARES INGRESADOS : %d\n",pares);
        printf("IMPARES INGRESADOS : %d\n",impares);
        return 0;
    }
    

    C++

             
    #include<iostream>
    using namespace std;
    int main() {
        int contador, impares, pares, array[10];
        // Cargar Array - 10 Números Impares
        for (contador=0;contador<=9;contador++) {
            cout << "Ingrese Numero " << contador+1 << " : ";
            cin >> array[contador];
        }
        // Mostrar Array
        pares = 0;
        impares = 0;
        for (contador=0;contador<=9;contador++) {
            if (array[contador]%2==0) {
                pares = pares+1;
            } else {
                impares = impares+1;
            }
        }
        cout << endl << "PARES INGRESADOS : " << pares << endl;
        cout << "IMPARES INGRESADOS : " << impares << endl;
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir