Mostrar Números Menores a Diez

¡Haz clic para puntuar este proyecto!
(Votos: 4 Promedio: 4.3)

Elaborar un programa que ingrese 20 números aleatorios a un array y mostrar una lista de los números menores o iguales que 10 que hayan sido ingresados.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Dimension vector[20]
        //Ingresa 20 números aleatorios al array
        Para f = 1 hasta 20 con paso 1 hacer			
            Escribir "Ingrese Número ", f, " : "		
            Leer vector[f]				
        FinPara		
        //Muestra la lista de números menores que 10
        Para f = 1 hasta 20 con paso 1 hacer					
            Si vector[f] <= 10 Entonces
                Escribir "vector[",f,"]=", vector[f]		
            Fin Si		
        FinPara
    FinAlgoritmo
    

    Lenguaje C

       
    #include<stdio.h>
    int main() {
        int f, vector[20];
        /* Ingresa 20 números aleatorios al array */
        for (f=0;f<=19;f+=1) {
            printf("Ingrese Numero %d : ",f);
            scanf("%i",&vector[f]);
        }
        /* Muestra la lista de números menores que 10 */
        for (f=0;f<=19;f+=1) {
            if (vector[f]<=10) {
                printf("vector[%d]=%d\n",f,vector[f]);
            }
        }
        return 0;
    }
    

    C++

       
    #include<iostream>
    using namespace std;
    int main() {
        int f, vector[20];
        // Ingresa 20 números aleatorios al array
        for (f=0;f<=19;f++) {
            cout << "Ingrese Numero " << f << " : ";
            cin >> vector[f];
        }
        // Muestra la lista de números menores que 10
        for (f=0;f<=19;f++) {
            if (vector[f]<=10) {
                cout << "vector[" << f << "]=" << vector[f] << endl;
            }
        }
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir