PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

04. Ordenar array - Ascendente.

Ingresar 10 números al azar o aleatorios a un array y mostrar dicho array ordenado en forma ascendente.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_04
	
    Dimension lista[10]
	
    //Ingresa 10 números aleatorios al array
    Para contador = 1 hasta 10 con paso 1 hacer			
        Escribir "Ingrese Número ", contador, " : "		
        Leer lista[contador]				
    FinPara
	
    //Ordena Array de forma Ascendente
    Para f <- 1 hasta 10 con paso 1 hacer			
        Para fx <- f hasta 10 con paso 1 hacer			
            Si lista[f] > lista[fx] Entonces
                A <- lista[f];
                lista[f] <- lista[fx];
                lista[fx] <- A;					
            FinSi
        FinPara	
    FinPara
	
    //Muestra Array ordenado
    Para contador = 1 hasta 10 con paso 1 hacer			
        Escribir Sin Saltar lista[contador], " ";
    FinPara
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_04
	
	Definir lista, f, fx, A como Entero;
	Dimension lista[10];
	
    //Ingresa 10 números aleatorios al array
    Para f <- 0 hasta 9 con paso 1 hacer			
        Escribir "Ingrese Número ", f, " : ";
        Leer lista[f];
    FinPara
		
    //Ordena Array de forma Ascendente
    Para f <- 0 hasta 9 con paso 1 hacer			
        Para fx <- f hasta 9 con paso 1 hacer			
            Si lista[f] > lista[fx] Entonces
                A <- lista[f];
                lista[f] <- lista[fx];
                lista[fx] <- A;					
            FinSi
        FinPara	
    FinPara
	
    //Muestra Array Ordenado
    Para f <- 0 hasta 9 con paso 1 hacer					
        Escribir lista[f];
    FinPara
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
int main() {
    int a, f, fx, lista[10];
	
    /* Ingresa 10 números aleatorios al array */
    for (f=0;f<=9;f+=1) {
        printf("Ingrese Numero %d : ",f);
        scanf("%i",&lista[f]);
    }
    
    /* Ordena Array de forma Ascendente */
    for (f=0;f<=9;f+=1) {
        for (fx=f;fx<=9;fx+=1) {
            if (lista[f]>lista[fx]) {
                a = lista[f];
                lista[f] = lista[fx];
                lista[fx] = a;
            }
        }
    }
    
    /* Muestra Array Ordenado */
    for (f=0;f<=9;f+=1) {
        printf("%d\n",lista[f]);
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main() {
    int a, f, fx, lista[10];
	
    // Ingresa 10 numeros aleatorios al array
    for (f=0;f<=9;f++) {
        cout << "Ingrese Numero " << f << " : ";
        cin >> lista[f];
    }
	
    // Ordena Array de forma Ascendente
    for (f=0;f<=9;f++) {
        for (fx=f;fx<=9;fx++) {
            if (lista[f]>lista[fx]) {
                a = lista[f];
                lista[f] = lista[fx];
                lista[fx] = a;
            }
        }
    }
	
    // Muestra Array Ordenado
    for (f=0;f<=9;f++) {
        cout << lista[f] << endl;
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    lista = [int() for ind0 in range(10)]
	
    # Ingresa 10 números aleatorios al array
    for f in range(10):
        print("Ingrese Número ",f," : ")
        lista[f] = int(input())
    
    # Ordena Array de forma Ascendente
    for f in range(10):
        for fx in range(f,10):
            if lista[f]>lista[fx]:
                a = lista[f]
                lista[f] = lista[fx]
                lista[fx] = a
                
    # Muestra Array Ordenado
    for f in range(10):
        print(lista[f])
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site