Promediar tres vectores

¡Haz clic para puntuar este proyecto!
(Votos: 15 Promedio: 4)

Sumar tres vectores y mostrar el promedio en un cuarto vector.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeint_Site
        Dimension n1[8]
        Dimension n2[8]
        Dimension n3[8]
        Dimension pro[8]
        //Ingresa 8 notas al array n1, n2 y n3
        Para f = 1 hasta 8 con paso 1 hacer			
            Escribir "INGRESE 3 NOTAS : ", f 
            Escribir "Ingrese Nota 1: "
            Leer n1[f]
            Escribir "Ingrese Nota 2: "
            Leer n2[f]
            Escribir "Ingrese Nota 3: "
            Leer n3[f]
        FinPara		
        //Muestra y Calcula los tres promedios
        Para f = 1 hasta 8 con paso 1 hacer						
            Escribir n1[f]," + ",n2[f]," + ",n3[f]," = ",(n1[f]+n2[f]+n3[f])/3
        FinPara	
    FinAlgoritmo
    

    Lenguaje C

        
    #include<stdio.h>
    int main() {
        int f;
        int n1[8];
        int n2[8];
        int n3[8];
        int pro[8];
        /* Ingresa 8 notas al array n1, n2 y n3 */
        for (f=0;f<=7;f+=1) {
            printf("\nINGRESE 3 NOTAS : %d\n",f+1);
            printf("Ingrese Nota 1: ");
            scanf("%i",&n1[f]);
            printf("Ingrese Nota 2: ");
            scanf("%i",&n2[f]);
            printf("Ingrese Nota 3: ");
            scanf("%i",&n3[f]);
        }
        /* Muestra y Calcula los tres promedios */
        printf("\n");
        for (f=0;f<=7;f+=1) {
            printf("%d+%d+%d=%d\n",n1[f],n2[f],n3[f],(n1[f]+n2[f]+n3[f])/3);
        }
        return 0;
    }
    

    C++

      
    #include<iostream>
    using namespace std;
    int main() {
        int f;
        int n1[8];
        int n2[8];
        int n3[8];
        int pro[8];
        // Ingresa 8 notas al array n1, n2 y n3
        for (f=0;f<=7;f++) {
            cout << "\nINGRESE 3 NOTAS : " << f+1 << endl;
            cout << "Ingrese Nota 1: ";
            cin >> n1[f];
            cout << "Ingrese Nota 2: ";
            cin >> n2[f];
            cout << "Ingrese Nota 3: ";
            cin >> n3[f];
        }
        // Muestra y Calcula los tres promedios
        cout << " " << endl;
        for (f=0;f<=7;f++) {
            cout << n1[f] <<"+"<< n2[f] <<"+"<< n3[f] <<"="<< (n1[f]+n2[f]+n3[f])/3 << endl;
        }
        return 0;
    }
    

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada.

    Subir