PSEINT.SITE

PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, Excel

Descarga pseint portable, cursos de C++, curso de visual studio, curso de java, curso creación de páginas web, crear sitio web y todo de como se hacen las páginas web.

Huawei Phone Clone nos permite transferir documentos en muy pocos segundos, soporte para instalar una app para el manejo de archivos y programación.

RESUELVO TUS ALGORITMOS (+51)954263896

09. Promediar tres vectores

Sumar tres vectores y mostrar el promedio en un cuarto vector.


DESCARGA CÓDIGOS

  PSeInt
  C - C++
  Python



PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_09
	
    Dimension n1[8]
    Dimension n2[8]
    Dimension n3[8]
    Dimension pro[8]
	
    //Ingresa 8 notas al array n1, n2 y n3
    Para f = 1 hasta 8 con paso 1 hacer			
        Escribir "INGRESE 3 NOTAS : ", f 
		
        Escribir "Ingrese Nota 1: "
        Leer n1[f]
        Escribir "Ingrese Nota 2: "
        Leer n2[f]
        Escribir "Ingrese Nota 3: "
        Leer n3[f]
    FinPara		
	
    //Muestra y Calcula los tres promedios
    Para f = 1 hasta 8 con paso 1 hacer						
        Escribir n1[f]," + ",n2[f]," + ",n3[f]," = ",(n1[f]+n2[f]+n3[f])/3
    FinPara	
	
FinAlgoritmo
    

PSeInt - ESTRICTO DESCARGA CÓDIGO

    
Algoritmo Array_Unidimencional_09
	
    Definir n1, n2, n3, pro, f como Entero;
	
    Dimension n1[8];
    Dimension n2[8];
    Dimension n3[8];
    Dimension pro[8];
	
    //Ingresa 8 notas al array n1, n2 y n3
    Para f <- 0 hasta 7 con paso 1 hacer			
        Escribir "INGRESE 3 NOTAS : ", f + 1;
		
        Escribir "Ingrese Nota 1: ";
        Leer n1[f];
        Escribir "Ingrese Nota 2: ";
        Leer n2[f];
        Escribir "Ingrese Nota 3: ";
        Leer n3[f];
    FinPara		
	
    //Muestra y Calcula los tres promedios
    Para f <- 0 hasta 7 con paso 1 hacer						
        Escribir n1[f],"+",n2[f],"+",n3[f],"=",(n1[f]+n2[f]+n3[f])/3;
    FinPara	
	
FinAlgoritmo
    

Lenguaje C DESCARGA CÓDIGO

        
#include<stdio.h>
int main() {
    int f;
    int n1[8];
    int n2[8];
    int n3[8];
    int pro[8];
	
    /* Ingresa 8 notas al array n1, n2 y n3 */
    for (f=0;f<=7;f+=1) {
        printf("\nINGRESE 3 NOTAS : %d\n",f+1);
        printf("Ingrese Nota 1: ");
        scanf("%i",&n1[f]);
        printf("Ingrese Nota 2: ");
        scanf("%i",&n2[f]);
        printf("Ingrese Nota 3: ");
        scanf("%i",&n3[f]);
    }
    /* Muestra y Calcula los tres promedios */
    printf("\n");
    for (f=0;f<=7;f+=1) {
        printf("%d+%d+%d=%d\n",n1[f],n2[f],n3[f],(n1[f]+n2[f]+n3[f])/3);
    }
    return 0;
}
    

C++ DESCARGA CÓDIGO

       
#include<iostream>
using namespace std;
int main() {
    int f;
    int n1[8];
    int n2[8];
    int n3[8];
    int pro[8];
	
    // Ingresa 8 notas al array n1, n2 y n3
    for (f=0;f<=7;f++) {
        cout << "\nINGRESE 3 NOTAS : " << f+1 << endl;
        cout << "Ingrese Nota 1: ";
        cin >> n1[f];
        cout << "Ingrese Nota 2: ";
        cin >> n2[f];
        cout << "Ingrese Nota 3: ";
        cin >> n3[f];
    }
    // Muestra y Calcula los tres promedios
    cout << " " << endl;
    for (f=0;f<=7;f++) {
        cout << n1[f] <<"+"<< n2[f] <<"+"<< n3[f] <<"="<< (n1[f]+n2[f]+n3[f])/3 << endl;
    }
    return 0;
}
    

Python DESCARGA CÓDIGO

    
if __name__ == '__main__':
    n1 = [int() for ind0 in range(8)]
    n2 = [int() for ind0 in range(8)]
    n3 = [int() for ind0 in range(8)]
    pro = [int() for ind0 in range(8)]
    # Ingresa 8 notas al array n1, n2 y n3
    for f in range(8):
        print("INGRESE 3 NOTAS : ",f+1)
        print("Ingrese Nota 1: ")
        n1[f] = int(input())
        print("Ingrese Nota 2: ")
        n2[f] = int(input())
        print("Ingrese Nota 3: ")
        n3[f] = int(input())
    # Muestra y Calcula los tres promedios
    for f in range(8):
        print(n1[f],"+",n2[f],"+",n3[f],"=",(n1[f]+n2[f]+n3[f])/3)
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site