Llenar un vector de números aleatorios

¡Haz clic para puntuar este proyecto!
(Votos: 2 Promedio: 3)

Realizar la operación para llenar de forma aleatoria un vector de números enteros y contar cuantos números que están almacenados en el vector son números primos.

¿En que programa quieres ver el Código? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeInt_Site
        Escribir "TAMAÑO DEL VECTOR : "
        Leer N	
        Dimension vector[N]
        Para f = 1 Hasta N Con Paso 1 Hacer
            vector[f] = Azar(50)
            Escribir Sin Saltar vector[f], " "
        FinPara
        Escribir " "
        Escribir " "
        Escribir "NÚMERO PRIMOS"
        Para f = 1 Hasta N Con Paso 1 Hacer
            r = 0;		
            Para p = 1 Hasta vector[f] Con Paso 1 Hacer
                Si (vector[f] mod p == 0) Entonces
                    r = r + 1
                FinSi					
            FinPara				
            Si (r == 2) Entonces
                Escribir Sin Saltar vector[f], " "
                suma = suma + 1
            FinSi		
        FinPara
        Escribir " "
        Escribir " "	
        Escribir "TOTAL DE NÚMERO PRIMOS : ", suma
        Escribir " "
    FinAlgoritmo
    

     

    Deja una respuesta

    Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

    Subir