Algoritmos y Programación a Nivel Profesional

Códigos resueltos en PSeInt.Site, Lenguaje C, C++, Python, DFD 1.0, JavaCript, Java NetBeas, Visual Studio, VBA
Curso de autocad para mac, Curso de C, certificacion google ads, curso marketing digital google, Curso de creación de páginas Web

DESARROLLAMOS TUS ALGORITMOS (+51)954263896

LLENAR UN VECTOR DE NÚMEROS ALEATORIOS

14. Realizar la operación para llenar de forma aleatoria un vector de números enteros y contar cuantos números que están almacenados en el vector son números primos.


PSeInt - FLEXIBLE DESCARGA CÓDIGO

    
Algoritmo www_PSeInt_Site
	
    Escribir "TAMAÑO DEL VECTOR : "
    Leer N	
    Dimension vector[N]
	
    Para f = 1 Hasta N Con Paso 1 Hacer
        vector[f] = Azar(50)
        Escribir Sin Saltar vector[f], " "
    FinPara
	
    Escribir " "
    Escribir " "
    Escribir "NÚMERO PRIMOS"
	
    Para f = 1 Hasta N Con Paso 1 Hacer
        r = 0;		
        Para p = 1 Hasta vector[f] Con Paso 1 Hacer
            Si (vector[f] mod p == 0) Entonces
                r = r + 1
            FinSi					
        FinPara				
        Si (r == 2) Entonces
            Escribir Sin Saltar vector[f], " "
            suma = suma + 1
        FinSi		
    FinPara
	
    Escribir " "
    Escribir " "	
    Escribir "TOTAL DE NÚMERO PRIMOS : ", suma
    Escribir " "
	
FinAlgoritmo
    

PSeInt - UTP-Peru │ ESPE DESCARGA CÓDIGO

    
Algoritmo www_PSeInt_Site
	
    Definir f, N, p, vector, r, suma como Entero;
	
    suma <- 0;
	
    Escribir "TAMAÑO DEL VECTOR : ";
    Leer N;
	
    Dimension vector[N];
	
    Para f <- 1 Hasta N Con Paso 1 Hacer
        vector[f] <- Azar(50);
        Escribir Sin Saltar vector[f], " ";
    FinPara
	
    Escribir " ";
    Escribir " ";
    Escribir "NÚMERO PRIMOS";
	
    Para f <- 1 Hasta N Con Paso 1 Hacer
        r <- 0;
        Para p <- 1 Hasta vector[f] Con Paso 1 Hacer
            Si (vector[f] mod p == 0) Entonces
                r <- r + 1;	
            FinSi					
        FinPara		
        Si (r == 2) Entonces
            Escribir Sin Saltar vector[f], " ";
            suma <- suma + 1;
        FinSi
    FinPara
	
    Escribir " ";
    Escribir " ";	
    Escribir "TOTAL DE NÚMERO PRIMOS : ", suma;
    Escribir " ";
	
FinAlgoritmo
    



Aviso de Privacidad | Política de Cookies | Términos y condiciones

Derechos Reservados PSeInt.site